Troubleshoot upgrade to Splunk Enterprise Security version 8.x

Troubleshoot UI errors that might occur when upgrading to Splunk Enterprise Security version 8.0.

Issue

UI errors can occur when you upgrade to Splunk Enterprise version 10.x prior to upgrading to Splunk Enterprise Security version 8.x.

Cause

The size of the Splunk Enterprise Security app is larger than the upload limit allowed on the UI.

Solution

  • Upgrade to Splunk Enterprise Security version 8.x prior to upgrading to Splunk Enterprise version 10.x.
  • Alternatively, use the command line interface (CLI) to upload and install Splunk Enterprise Security version 8.0, then go back to the UI to configure Splunk Enterprise Security 8.0.

See also

For more information on upgrading Splunk Enterprise Security 8.x and higher, see Version-specific upgrade notes.